drm drivers for vc4 · Supported
Maintainers
- M Maxime Ripard <mripard@kernel.org>
- M Dave Stevenson <dave.stevenson@raspberrypi.com>
- R Maíra Canal <mcanal@igalia.com>
- R Raspberry Pi Kernel Maintenance <kernel-list@raspberrypi.com>
Paths
- F
Documentation/devicetree/bindings/display/brcm,bcm2835-*.yaml - F
drivers/gpu/drm/vc4/ - F
include/uapi/drm/vc4_drm.h
Last 30 days
Active reviewers (last 30 days)
-
Maxime Ripard <mripard@kernel.org>
8 attestations (5 Acked-by, 3 Suggested-by) · last on 2026-07-24 -
Dmitry Baryshkov <hidden>
2 attestations (2 Reviewed-by) · last on 2026-07-24 -
Dave Stevenson <dave.stevenson@raspberrypi.com>
2 attestations (2 Reviewed-by) · last on 2026-07-23
Recent patches
Most-recent 30 patches in this subsystem on linux-arm-kernel (capped at 30), ordered by date desc.
-
WARM3d
REVIEWED: 7 (6M) [PATCH v9 4/5] drm/debugfs: Move HDMI debugfs registration to state helper
2026-07-24 · Nicolas Frattaroli <nicolas.frattaroli@collabora.com> -
HOTtoday
[PATCH v9 16/61] drm/display: hdmi-state-helper: Pass acquire ctx to hotplug helpers
2026-07-23 · Cristian Ciocaltea <hidden> -
HOTtoday
[PATCH v9 39/61] drm/vc4: hdmi: Defer pixel clock validation to HDMI helpers
2026-07-23 · Cristian Ciocaltea <hidden> -
HOTtoday
[PATCH v9 38/61] drm/vc4: hdmi: Convert to common HDMI 2.0 scrambling infrastructure
2026-07-23 · Cristian Ciocaltea <hidden> -
HOTtoday
[PATCH v9 37/61] drm/vc4: hdmi: Convert to drmm_connector_hdmi_init()
2026-07-23 · Cristian Ciocaltea <hidden> -
HOTtoday
REVIEWED: 6 (6M) [PATCH v9 35/61] drm/vc4: hdmi: Switch to drm_hdmi_mode_needs_scrambling()
2026-07-23 · Cristian Ciocaltea <hidden> -
HOTtoday
[PATCH v9 36/61] drm/vc4: hdmi: Propagate -EDEADLK to the top level
2026-07-23 · Cristian Ciocaltea <hidden> -
HOTtoday
REVIEWED: 10 (10M) [PATCH v9 34/61] drm/vc4: hdmi: Use common TMDS char rate constants
2026-07-23 · Cristian Ciocaltea <hidden> -
HOTtoday
[PATCH v9 02/61] drm/display: hdmi: Rename drmm_connector_hdmi_init() to *_ini2()
2026-07-23 · Cristian Ciocaltea <hidden> -
COOLING9d
REVIEWED: 7 (6M) [PATCH v8 4/5] drm/debugfs: Move HDMI debugfs registration to state helper
2026-07-22 · Nicolas Frattaroli <nicolas.frattaroli@collabora.com> -
COOLING9d
[PATCH v7 4/5] drm/debugfs: Move HDMI debugfs registration to state helper
2026-07-21 · Nicolas Frattaroli <nicolas.frattaroli@collabora.com> -
COOLING9d
[PATCH v8 31/39] drm/vc4: hdmi: Convert to common SCDC scrambling infrastructure
2026-07-02 · Cristian Ciocaltea <hidden> -
COOLING9d
REVIEWED: 10 (10M) [PATCH v8 29/39] drm/vc4: hdmi: Use common TMDS char rate constants
2026-07-02 · Cristian Ciocaltea <hidden> -
COOLING9d
[PATCH v8 30/39] drm/vc4: hdmi: Switch to drm_hdmi_mode_needs_scrambling()
2026-07-02 · Cristian Ciocaltea <hidden> -
COOLING9d
[PATCH v8 10/39] drm/display: hdmi-state-helper: Sync SCDC state on hotplug
2026-07-02 · Cristian Ciocaltea <hidden> -
COOLING9d
[PATCH v7 25/30] drm/vc4: hdmi: Convert to common HDMI 2.0 SCDC scrambling helpers
2026-06-01 · Cristian Ciocaltea <hidden> -
COOLING9d
[PATCH v7 24/30] drm/vc4: hdmi: Use common TMDS char rate constants
2026-06-01 · Cristian Ciocaltea <hidden> -
COLD39d
REVIEWED: 12 (11M) [PATCH v6 14/19] drm/hdmi: Rename __drm_atomic_helper_connector_hdmi_reset()
2026-05-26 · Maxime Ripard <mripard@kernel.org> -
STALE66d
REVIEWED: 12 (11M) [PATCH v5 14/19] drm/hdmi: Rename __drm_atomic_helper_connector_hdmi_reset()
2026-05-19 · Maxime Ripard <mripard@kernel.org> -
STALE78d
REVIEWED: 12 (11M) [PATCH v4 14/20] drm/hdmi: Rename __drm_atomic_helper_connector_hdmi_reset()
2026-05-12 · Maxime Ripard <mripard@kernel.org> -
STALE80d
REVIEWED: 8 (7M) [PATCH v3 14/20] drm/hdmi: Rename __drm_atomic_helper_connector_hdmi_reset()
2026-04-24 · Maxime Ripard <mripard@kernel.org> -
STALE123d
[PATCH v3 3/3] drm/gem-dma: Support DRM_MODE_DUMB_KERNEL_MAP flag
2026-03-26 · Chen-Yu Tsai <wenst@chromium.org> -
STALE123d
[PATCH v3 2/3] drm/gem-dma: Use the dma_*_attr API variant
2026-03-26 · Chen-Yu Tsai <wenst@chromium.org> -
STALE98d
[PATCH v2 12/20] drm/hdmi: Rename __drm_atomic_helper_connector_hdmi_reset()
2026-03-20 · Maxime Ripard <mripard@kernel.org> -
STALE134d
[PATCH v2 3/4] drm/gem-dma: Use the dma_*_attr API variant
2026-03-17 · Chen-Yu Tsai <wenst@chromium.org> -
STALE129d
LANDED: 1 (0M) [PATCH v3 14/14] drm/display: hdmi: Use drm_output_color_format instead of hdmi_colorspace
2026-03-05 · Maxime Ripard <mripard@kernel.org> -
STALE151d
REVIEWED: 1 (0M) [PATCH v2 14/14] drm/display: hdmi: Use drm_output_color_format instead of hdmi_colorspace
2026-02-27 · Maxime Ripard <mripard@kernel.org> -
STALE154d
[PATCH 14/14] drm/display: hdmi: Use drm_output_color_format instead of hdmi_colorspace
2026-02-24 · Maxime Ripard <mripard@kernel.org> -
STALE184d
REVIEWED: 6 (6M) [PATCH v4 06/10] drm/display: hdmi_state_helper: split InfoFrame functions per type
2026-01-07 · Dmitry Baryshkov <hidden> -
STALE184d
REVIEWED: 6 (6M) [PATCH v4 02/10] drm/vc4: hdmi: implement clear_infoframe
2026-01-07 · Dmitry Baryshkov <hidden>
Needs attention (review trailers in, no pickup)
Patches with review trailers that haven't landed in mainline and haven't been Acked by a maintainer. Oldest first.
-
STALE151d
REVIEWED: 1 (0M) [PATCH v2 14/14] drm/display: hdmi: Use drm_output_color_format instead of hdmi_colorspace
2026-02-27 · Maxime Ripard <mripard@kernel.org> · 1 Acked-by -
STALE80d
REVIEWED: 8 (7M) [PATCH v3 14/20] drm/hdmi: Rename __drm_atomic_helper_connector_hdmi_reset()
2026-04-24 · Maxime Ripard <mripard@kernel.org> · 2 Reviewed-by -
STALE78d
REVIEWED: 12 (11M) [PATCH v4 14/20] drm/hdmi: Rename __drm_atomic_helper_connector_hdmi_reset()
2026-05-12 · Maxime Ripard <mripard@kernel.org> · 3 Reviewed-by -
STALE66d
REVIEWED: 12 (11M) [PATCH v5 14/19] drm/hdmi: Rename __drm_atomic_helper_connector_hdmi_reset()
2026-05-19 · Maxime Ripard <mripard@kernel.org> · 3 Reviewed-by -
COLD39d
REVIEWED: 12 (11M) [PATCH v6 14/19] drm/hdmi: Rename __drm_atomic_helper_connector_hdmi_reset()
2026-05-26 · Maxime Ripard <mripard@kernel.org> · 3 Reviewed-by
Quiet for 30+ days
Patches with no review trailers and no replies. Either the author is heads-down elsewhere or these slipped through. Oldest first.
-
STALE134d
[PATCH v2 3/4] drm/gem-dma: Use the dma_*_attr API variant
2026-03-17 · Chen-Yu Tsai <wenst@chromium.org>